Cloud Dashboard and Corporate website unreachable

Incident Report for Fluxzero

Postmortem

Cloud dashboard

Dashboard UI is hosted/provided via the Cloudflare network.
See https://blog.cloudflare.com/18-november-2025-outage/ for Cloudlfare's account of the root cause and its effect on the global internet.

Corporate website and documentation

These pages are hosted/provided via the Cloudflare network.
See https://blog.cloudflare.com/18-november-2025-outage/ for Cloudlfare's account of the root cause and its effect on the global internet.

Future

We regret the affect on our customer of this outage and will be investigating mitigations of such occurrences in the future. Especially for our Fluxzero cloud customers when we move out of private-beta phases we aim to keep the dashboard running in these events.

Please do reach out to us with any questions/progress related to this outage.

Posted Nov 19, 2025 - 09:22 UTC

Resolved

Due to global outages of Cloudflare our Cloud dashboard and corporate website show Cloudflare error pages to most of our customers and visitors.

For Customers of our private beta Fluxzero Cloud with existing clusters (and running applications):
- All applications and cluster traffic is unaffected because this is not routed trough Cloudflare
- Deployments can still proceed trough CICD

What is affected:
- Creation of new clusters
- (re)deployment of configuration of Clusters/Applications due to the dashboard issues

See https://blog.cloudflare.com/18-november-2025-outage/ for Cloudlfare's account of the root cause and its effect on the global internet.
Posted Nov 18, 2025 - 10:30 UTC